Calibrating Extruder

I found that the OpenGB Calibration process varies slightly from the GB process in the re3D Wiki. This worked for me, but is not approved by re3D so use your discretion in following my guide.

Calibrating the filament feed

Correct extrusion quantity is important for quality prints. If the extruder is pushing too much plastic layers will overfill resulting in bumpy and uneven surfaces. Extruding too little plastic will cause weak bonds and gaps between layers resulting in a weak structure.

  1. Connect Open Gigabot's USB cable to your computer
  2. Turn on Open Gigabot
  3. Start Pronterface
  4. Click on <Connect> button at the top of the screen

Read the current extruder calibration number in Pronterface

Pronterface will display:

echo:Stored settings retrieved
echo:Steps per unit:
echo:  M92 X118.52 Y118.52 Z4031.50 E1000.00
  1. Check that filament is installed in extruder
  2. Heat hot-end to suit your filament
  3. When hot-end is up to temperature extrude 10mm of filament at 60mm/sec until you see filament coming out of the hot-end

    NOTE: I found the recommended 100mm/sec feed to be too fast for OGB and cause the extruder drive to jump teeth.
  1. Mark the filament 100mm and 150mm from rear filament tube shelf
  2. Extrude 80mm of filament using Pronterface
  3. Measure actual extrusion distance

    Deduct what is remaining from either your 100 or 150 mm marks
    i.e. 100 mm mark with 15 mm remaining equals 85 mm of filament feed

  4. Perform Calculation

    (Commanded distance x old calibration number) / actual extrusion distance = new calibration number

    (80 x 1000) / 85 = 941

In Pronterface:

  1. Type “M92 E941” <enter>
  2. Type “G92 E0” <enter>
Repeat the steps above to verify the extruder moves exactly 80mm when commanded.

In my case I ended up with my second calculation being

(80 * 941) / 81 = 923.4

I rounded up to 930 which seemed to work perfectly

Save the new extruder calibration (M92 Exxxx)

Simplify3D >> Edit Process Settings >> Scripts tab >> Starting Script tab >> Fourth line - Change "M92 E1000 ; calibrate E" to reflect whatever your E number is

Slicer-> Printer Settings -> Custom G-code -> Start G-code (M92 E1000 ; calibrate E)  (Unconfirmed...)


Open the OpenGB Config File in Notepad or Notepad++ and replace the four instances of "M92 E1000 ; calibrate E" with "M92 Exxx ; calibrate E" substituting your calculated E value


Please sign in to leave a comment.